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1. GENERAL INFORMATION

Dear Customer,
thank you for choosing our product. In the following, we will show you
what to pay attention to during commissioning and use.

If you encounter any unexpected problems during use, please feel free to
contact us.

2. CHANGE OF THE 12C ADDRESS

This analog to digital converter (or in short ADC) can be configured to 4
different 12C addresses. These can be chosen freely, but in the further
course the standard address 0x48 is used.

In the following table you can see all possible addresses and also how to
configure them. The main thing to note here is that the ADDR pin of the
ADC is responsible for changing the address.

Von Zu Adresse
ADDR Pin GND Pin 0x48
ADDR Pin VDD Pin 0x49
ADDR Pin SDA Pin Ox4A
ADDR Pin SCL Pin 0x4B

The state of the ADDR pin is continuously sampled. Be sure to connect
the ADDR pin to the other pins while ensuring the possibility of further
connection.

3. PIN ASSIGNMENT

In this section we briefly explain the functions of each pin.

VDD & GND: Power supply VDD KY—053'
O - iov-ic

SCL & SDA: 12C interface

ADDR: Used to select the 12C slave
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ALRT: Used to send a signal when
the conversion is ready or when the o AO
comparator output is ready. - ° Al mmmmEm

A0 to A4: Analog inputs.




4. USE WITH THE RASPBERRY PI

4.1 Connection

Raspberry Pi KY-053 External
3,3V VDD -
GND GND =
SCL (Pin 5) SCL -
SDA (Pin 3) SDA -
- ADDR -
. ALRT .
- A0 Analog signal source to be
measured
- Al Analog signal source to be
measured
- A2 Analog signal source to be
measured
- A3 Analog signal source to be

measured




Here the analog-digital converter is connected to 3.3 V. This means that
the converter can only measure 3.3 V on the analog inputs without
suffering permanent damage.

The voltage on the analog inputs must not be higher than the supply
voltage.

If you want to operate the analog-digital converter with 5V, you need a
voltage converter for the data lines, because the Raspberry Pi can be
damaged at a logic level of 5 V.

4.2 Installation
First you need to enable 12C on your Raspberry Pi. To open the configura-
tion, enter the following command:

sudo raspi-config

There select 3 Interface Options » P5 I2C.

] Raspberry P1 Software Configuration Tool {raspi-config) F

1 System Options Configure system settings
2 Display Options Configure display settings

p
Interface Options Configure connections to peripherals

4 Performance Options Configure perfermance settings

5 Localisation Options Configure language and regional settings

6 Advanced Options Configure advanced settings

8 Update Update this tool to the latest version

9 About raspi-config Informatien about this configuration tool

<select= <Finish>

] Raspberry P1 Software Configuration Tool (raspi-config) |
Pl Camera Enable/disable connection to the Raspberry Pi Camera
P2 SSH Enable/disable remote command line access using SSH
P3 VNC Enable/disable graphical remote access using RealVNC

P4 SPIL Enable/disable automatic loading of SPI kernel module
p5 12C Enable/d1isable automatic loading of I2C kernel module
P6 Serial Port Enable/disable shell messages on the serial connection
P7 1-Wire Enable/disable one-wire interface

P8 Remote GPIO Enzble/disable remote access to GPIO pins

=Select= <Back=

There you get the question Would you like the ARM [2C Interface to be
enabled?Confirm this with Yes.

would you like the ARM I2C interface to be enabled? The ARM I2C 1interface 1s enabled

You have now successfully activated 12C. The analog-to-digital converter
is now accessible under the 12C address 0x48, which is set by default for
this sensor. The 12C address will be different if you have already
configured it before configuring your Raspberry Pi.

We use the Adafruit_CircuitPython ADS1x15 library for our code
example, which is released under the MIT license. Use the following
commands to download and install this library.

sudo pip3 install adafruit-circuitpython-ads1x15


https://github.com/adafruit/Adafruit_CircuitPython_ADS1x15
https://github.com/adafruit/Adafruit_CircuitPython_ADS1x15/blob/main/LICENSE
https://joy-it.net/en/products/COM-KY051VT

4.3. code example
Then, after you have downloaded the library, all you need to do is to
execute the following command

nano KY@53ADC.py

to create a new file on your Raspberry Pi and then copy the following
code into the file you just created or download it here.

import time

import board

import busio

import adafruit_ads1x15.ads1115 as ADS

from adafruit_adslx15.analog_in import AnalogIn

# Create the I2C bus
i2c = busio.I2C(board.SCL, board.SDA)

# Creating the ADC object via the I2C bus
ads = ADS.ADS1115(i2c)

# Create single-ended input on channels
chan® = AnalogIn(ads, ADS.P®)

chanl = AnalogIn(ads, ADS.P1)
chan2 = AnalogIn(ads, ADS.P2)
chan3 = AnalogIn(ads, ADS.P3)

while True:

print("channel 0: ","{:>5}\t{:>5.3f}".format
(chan@.value, chan@.voltage))

print("channel 1: ","{:>5}\t{:>5.3f}".format
(chanl.value, chanl.voltage))

print("channel 2: ","{:>5}\t{:>5.3f}".format
(chan2.value, chan2.voltage))

print("channel 3: ","{:>5}\t{:>5.3f}".format
(chan3.value, chan3.voltage))

time.sleep(1)

In this code example, the digital value with the corresponding
voltage of the individual inputs is displayed. The measurements of an
input to which no voltage is applied are faulty and are therefore not
representative.

You can then save the code sample with CTRL+O and close it with
CTRL+X.

Afterwards you only need to execute the code sample with the following
command.

python3 KYO53ADC.py


https://joy-it.net/files/files/Produkte/COM-KY053ADC/COM-KY053ADC-RPi.zip

5. USE WITH THE ARDUINO

5.1 Connection

VDD KY—053.
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A5/SCL
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Arduino External
3,3V VDD -
GND GND -
SCL (A5) SCL -
SDA (A4) SDA -
- ADDR -
- ALRT -
- A0 Analog signal source to be
measured
- Al Analog signal source to be
measured
- A2 Analog signal source to be
measured
- A3 Analog signal source to be
measured

Here the analog-digital converter is connected to 5 V. This means that the
converter can only measure 5V on the analog inputs without suffering
permanent damage.

The voltage on the analog inputs must not be higher than the supply
voltage.




5.2 Installation

For our code example we use the library ADS1X15 by RobTillaart, which
is released under the MIT license. You can install this library by searching
for ADS1X15 under Sketch » Include Library » Manage Libraries...
Now you just have to click on the Install button.

5.3 Code example

To test your ADC with a code example, simply go to File » Examples >
ADS1X15 in your Arduino IDE and then ADS_read.... Click Upload to
upload the code example to your Arduino. Then, to get the output of the
sample code displayed, open the serial monitor with a baud rate of
115200. You can also download the code sample here.

In this code example, the digital value with the corresponding
voltage of the individual inputs is displayed. The measurements of an
input to which no voltage is applied are faulty and are therefore not
representative.

6. USE WITH THE MICRO:BIT

6.1 Connection
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Micro:Bit KY-053 External

3,3V VDD -
GND GND -
Pin 19 SCL -
Pin 20 SDA -
- ADDR -
- ALRT -

- A0 Analog signal source to be

measured



https://github.com/RobTillaart/ADS1X15
https://github.com/RobTillaart
https://github.com/RobTillaart/ADS1X15/blob/master/LICENSE
https://joy-it.net/files/files/Produkte/COM-KY053ADC/COM-KY053ADC-ARD.zip

- Al Analog signal source to be

measured

- A2 Analog signal source to be
measured

- A3 Analog signal source to be
measured

You may need to use a breakout board to connect cables to some pins of
your Micro:Bit. In this example a breakout board is used. We recommend
the breakout board for Micro:Bit from Joy-IT.

6.2 Installation
For control we recommend the use of the pxt-ads1115 library, which
was published by us under the MIT license.

You can add the library by clicking Extensions on the Makecode page
and then typing ADS1115 in the search bar. After you have done that, you
just need to click on the extension to add it automatically for your current
project.
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g AD51115 : .
KY-053 ANALOG-DIGITAL CONVERTER

6.3 Code example
To test your ADC you can download a code example from us here or
simply rebuild the code yourself as shown below.

If you have decided to download our code sample, then after unzipping
the file you can simply drag and drop the contents onto the Makecode
web page and release to import the file and open it automatically.

on start forever

Set the mode to MULTI w serial write line Read on channel e

serial write string Read on channel ° value to voltage

Set the gain to TWO *

Set the sample rate to RATE5_128SPS w

serial write line “
serial write line -

pause (ms) @24

Initialize ADS1115 with address GND_Ox48 ¥



https://github.com/joy-it/pxt-ads1115
https://github.com/joy-it
https://github.com/joy-it/pxt-ads1115/blob/main/LICENSE
https://makecode.microbit.org/#editor
https://joy-it.net/files/files/Produkte/COM-KY053ADC/COM-KY053ADC-MB.zip
https://joy-it.net/en/products/MB-CONN02

6.4 Pairing the Micro:Bit
Click on the button located to the right of Upload/Download.
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Set the mode to MULTI ¥ serial write line = Read on channel °

Set the gain to TWO ¥ serial write string = Read on channel e value to voltage

Set the sample rate to RATE5_1285PS v . _— '
Led = serial write line
e

Initialize ADS1115 with address GND @xds v i — -
ADS1115
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Search.. Q

Basic
Set the mode to MULTLI ¥
© Input
Set the gain to TWO ¥
&» Music
Set the sample rate to RATE5_1285PS w
© Led
Initialize AD51115 with address GND_8x48 v
O ADs1115
Radio
C' Loops Connect your micro:bit...
23 Logic
= Variables
B Math

First, make sure your micro:bit is connected to
your computer with a USB cable.

@ Extensions

I v Advanced

forever

serial write line  Read on channel o

serial write string = Read on channel ° value to valtage

serial write Line a
serial write line (NN

pause (ns) (g

Download KY-053

Click Next.

Microsoft | € micro

Search... Q

Set the mode to MULTLI ¥
© Input
&» Music

Set the gain to TWO ¥

Set the sample rate to RATES 1285PS w

© Led

Initialize ADS1115 with address GND_0x48 ¥

O Aps1115
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C Loops
24 Logic

Connect your micro:bit...

= Variables

Pair your micro:bit to the computer by
B Math v puter oy

selecting ‘BBC micro:bit CMSIS-DAP or
DAPLink CMSIS-DAP' from the popup that
appears after you press the ‘Next' button
below.

© Extensions

I v Advanced

forever

serial write line = Read on channel o

serial write string = Read on channel ° value to voltage

serial write Line n
serial write line (NN

pause (ms) (g

( Ll Show data Simulator )




Select your Micro:Bit in the opened window and click Connect to connect
and use it.

makecode.microbit.org mochte eine Verbindung herstellen.

BBC micro:bit CMSIS-DAP

The last thing you need to do is click on Done to be able to upload your
code. You can upload the code by clicking on Download.

icrosoft | @ micro:bit k& Blocks

Search a

£52 Basic
© Input
@ Music
© Led

Q ADS1115 Initialize ADS1115 with address GND_©x48 v serial write line -
il Radio
C' Loops
23 Logic

set the mode to MULTI ¥ serial write line Read on channel °
Set the gain to TWO ¥ serial write string | Read on channel () value to vortege

Set the sample rate to RATES_1285PS v s 5
- serial write line

Q Connected to micro:bit 0

= Variables Your micro:bit is connected! Pressing
Download' will now automatically copy your

& Math y copy y
code to your micro:bit.

© Extensions

If you need to unpair this micro:bit, you can do
so through the " menu next to the ‘Download’

I v Advanced button

N
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N - O - T ]

Now that you have paired your Micro:Bit, you can open the serial output
and view your results.
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7. OTHER INFORMATION

Our information and take-back obligations according
to the Electrical and Electronic Equipment Act
(ElektroG)

Symbol on electrical and electronic equipment: E
R

This crossed-out dustbin means that electrical and electronic appliances
do not belong in the household waste. You must return the old applianc-
es to a collection point.

Before handing over waste batteries and accumulators that are not
enclosed by waste equipment must be separated from it.

Return options:

As an end user, you can return your old device (which essentially fulfills
the same function as the new device purchased from us) free of charge
for disposal when you purchase a new device.

Small appliances with no external dimensions greater than 25 cm can be
disposed of in normal household quantities independently of the
purchase of a new appliance.

Possibility of return at our company location during opening hours:

SIMAC Electronics GmbH, Pascalstr. 8, D-47506 Neukirchen-Vluyn,
Germany

Possibility of return in your area:

We will send you a parcel stamp with which you can return the device to
us free of charge. Please contact us by email at Service@joy-it.net or by
telephone.

Information on packaging:

If you do not have suitable packaging material or do not wish to use your
own, please contact us and we will send you suitable packaging.

7. SUPPORT

If there are still any issues pending or problems arising after your purcha-
se, we will support you by e-mail, telephone and with our ticket support
system.

Email: service@joy-it.net
Ticket system: http://support.joy-it.net
Telephone: +49 (0)2845 9360-50 (10-17 o‘clock)

For further information please visit our website:
www.joy-it.net

Published: 2.28.2023
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